SSL obligatorio con PayPal

Ultimas novedades en el sector, Noticias, Curiosidades

Re: SSL obligatorio con PayPal

Notapor PiLLaO » Sab Abr 01, 2017 12:58 pm

A mi me pasa al reves, el correo llega al dominio propio y da problemas al reenviar a gmail
PiLLaO
Administrador Foros
 
Mensajes: 1041
Registrado: Lun Ene 10, 2011 11:15 am
Ubicación: Málaga

Anuncio

web_empresa

Re: SSL obligatorio con PayPal

Notapor reflex_ocasion » Sab Abr 01, 2017 1:50 pm

gmail es gmail y no me extraña

Doy por hecho de que en tu hosting tienes los redireccionadores bien configurado pero ¿has consultado las FAQ a ver si hay algo que te diga que has de hacer algo mas que se te haya pasado? te recuerdo que no todos los hosting son iguales, lo que en uno funciona de una manera en otro funciona de otra como por ejemplo el redirect de http a https, el que a mi me funciona no funciona en otro hosting distinto

Salu2
reflex_ocasion
Moderador Global
 
Mensajes: 681
Registrado: Jue Ene 13, 2011 10:25 pm
Ubicación: Mijas Costa (Málaga)

Re: SSL obligatorio con PayPal

Notapor Famaca » Jue Abr 06, 2017 8:45 pm

Hola,

Yo tengo toda mi tienda oscommerce 2.3.4 con SSL. Mi hosting me instaló el certificado. Pero ahora resulta que al pagar con redsys no me pasa el pedido a la tienda ni recibo el correo de confirmación ¿Cómo habéis hecho para que funcione bien y se genere el pedido en la tienda?

Saludos
Famaca
Creo que ya empiezo a entenderlo...
 
Mensajes: 75
Registrado: Mié Mar 16, 2011 12:52 pm

Re: SSL obligatorio con PayPal

Notapor Famaca » Vie Abr 07, 2017 1:08 pm

He visto que en prestastashop si que hay una solución modificando el archivo redsys.php, pero como siempre oscommerce no pinta nada y al revisar el archivo no veo donde se pueda modificar el código para notificar en http. Si alguien consigue averiguar como, quizás sea la solución.

Saludos
Famaca
Creo que ya empiezo a entenderlo...
 
Mensajes: 75
Registrado: Mié Mar 16, 2011 12:52 pm

Re: SSL obligatorio con PayPal

Notapor Skualos » Sab Abr 15, 2017 2:00 pm

Vaya empanada mental con lo del ssl... me estallara la cabeeezaaaa!!! .. bueno, para quien le interese y tenga ganas o sepa como hacerlo
https://www.linuxito.com/seguridad/292- ... ssl-gratis
yo lo probe, y si.. genera una serie de codigos y fffff.. hace un monton de cosas, pero aun no se que hacer con ellas.

Tambien esta https://letsencrypt.org/

Ambas proporcionan certificados ssl gratuitos sin caducidad (o eso dicen).
Skualos
Moderador Global
 
Mensajes: 3169
Registrado: Mié Feb 09, 2011 9:17 pm
Ubicación: Palafrugell

Re: SSL obligatorio con PayPal

Notapor PiLLaO » Jue Abr 27, 2017 12:22 am

Famaca escribió:He visto que en prestastashop si que hay una solución modificando el archivo redsys.php, pero como siempre oscommerce no pinta nada y al revisar el archivo no veo donde se pueda modificar el código para notificar en http. Si alguien consigue averiguar como, quizás sea la solución.

Saludos

Hay que modificar las url_ok y url_ko

Salu2 :)
PiLLaO
Administrador Foros
 
Mensajes: 1041
Registrado: Lun Ene 10, 2011 11:15 am
Ubicación: Málaga

Re: SSL obligatorio con PayPal

Notapor Famaca » Jue Abr 27, 2017 10:02 am

Hola Pillao,

No sé exactamente a lo que te refieres con url_ok y url_ko ni cómo hacerlo, porque de programación entiendo lo justo. Yo al final apliqué, en el archivo redsys.php, un código que me dijo Figue , que por lo que me dijo es tuyo, y luego otro código en el archivo .htaccess. El caso es que ahora funciona todo, pero me pasa que al ir a la web de redsys, a notificaciones, me da, como le daba a figue el error 304, que es un error de redirección. Sin embargo, el error no afecta al funcionamiento. De modo que lo he dejado así.

Me comenta Figue que al final había eliminado esos cambios y lo ha dejado como estaba antes y funciona todo bien. Cosa que no entiendo. A mí tal como estaba no me funciona.

Gracias.

Saludos
Famaca
Creo que ya empiezo a entenderlo...
 
Mensajes: 75
Registrado: Mié Mar 16, 2011 12:52 pm

Re: SSL obligatorio con PayPal

Notapor reflex_ocasion » Jue Abr 27, 2017 11:19 am

A falta de verificarlo a ver si ahora me funciona, en el archivo .htaccess hay que añadir unas líneas de código que dependeran del tipo de servidor que tengamos en nuestro hosting. Para saber como lo tenemos configurado vamos a Herramientas -> Info del servidor donde buscaremos "Server API" que está al principio, no hay que ir muy lejos a buscar

Si es Apache o similar añadiremos a .htaccess lo siguiente:
Código: Seleccionar todo
php_flag session.use_only_cookies 0
php_flag suhosin.cookie.cryptua 0
php_flag suhosin.cookie.cryptdocroot 0
php_flag suhosin.session.cryptdocroot 0
php_flag suhosin.session.encrypt 0


Si es CGI, FastCGI o similar añadiremos a .htaccess esto otro:
Código: Seleccionar todo
session.use_only_cookies=Off
suhosin.cookie.cryptua=Off
suhosin.cookie.cryptdocroot=Off
suhosin.session.cryptdocroot=Off
suhosin.session.encrypt=Off


Actualmente tengo LiteSpeed y por fallo mio creia que era del tipo Apache pero resulta que es del tipo CGI. Creia que era Apache por haber visto el logo muchas veces en la página de información del servidor cuando estaba en otro hosting pero al cambiar al actual hosting no le he prestado atención porque, la verdad, es algo que no me ha hecho falta hasta ahora, he dado por sentado que era del mismo tipo (craso error) :black_eye:

Si no sabes realmente cual es el tipo de servidor que tienes en tu hosting busca información al respecto, San Google tiene la respuesta :mf_bookread:

Esto viene porque la causa más común es un problema con la configuración del php, a partir de la versión 5.3.3 ha cambiado el valor por defecto del parámetro “session.use_only_cookies” que antes estaba desactivado y ahora viene activado

Normalmente lo antes dicho es suficiente para solucionar el problema pero hay algunos hostings que no permiten el cambio de estas configuraciones usando este método por lo que la única solución que nos quedaría sería abrir un ticket y solicitar que nos hagan ellos el cambio

Como dije en un post anterior en este mismo hilo, a mi me fallaba la sesión, la perdía sin motivo aparente hasta que me dió por probar a cambiar a true lo de forzar el uso de cookies (Configuración -> Sesiones). Desde entonces ya no pierdo la sesión aunque sigue sin grabarme el pedido y por ende sigue sin enviar el email de confirmación de pedido. Ahora tan solo falta verificar si esto funciona y graba el pedido :mrgreen:

Ya os contaré si funciona o no, tengo que esperar a que me hagan una compra y paguen con tarjeta, como no tengo no puedo hacerla yo mismo :redface:

Por cierto, esto debería ir en el hilo del TPV, no en el de PayPal
reflex_ocasion
Moderador Global
 
Mensajes: 681
Registrado: Jue Ene 13, 2011 10:25 pm
Ubicación: Mijas Costa (Málaga)

Anterior

  • Temas Similares
    Respuestas
    Vistas
    Autor

Volver a Noticias

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados

cron